Vídeo Tutorial #17: Configurar VLANs en el Xiaomi Mi Router AX3600 y AX1800 sin cambiar el firmware

Domótica Tutoriales Xiaomi

Aunque todavía no parece haber nada funcional con OpenWRT para el AX3600, parece que hay buenas noticias para los que estamos esperando la posibilidad de ponerlo como router principal. Después de que un usuario por twitter (Victor Cruz) me mandara el link del vídeo en chino para configurar las VLANs, he podido realizar el vídeo en español para aclarar las posibles dudas que surjan ya que el otro estaba totalmente en chino.

Vídeo del tutorial para configurar las VLANs en el Xiaomi Mi Router AX3600 y AX1800

El tutorial es funcional tanto para el modelo AX3600 como el AX1800, eso si, tendremos que cambiar la versión a cada router, en función del modelo que tengamos:

  • Para los del Mi Router AX3600 tendremos que estar en la versión 1.0.17 que podéis descargar aquí.
  • Para los del Mi Router AX1800 tendréis que estar en la versión 1.0.34 que podréis descargar aquí.

Tal y como digo en el vídeo, aquí tenéis la linea que tendréis que copiar en la barra de direcciones, recordad que debéis borrar desde la “w” de web, dejando la barra:

 api/misystem/set_config_iotdev?bssid=Xiaomi&user_id=longdike&ssid=-h%3B%20nvram%20set%20ssh_en%3D1%3B%20nvram%20commit%3B%20sed%20-i%20's%2Fchannel%3D.*%2Fchannel%3D%5C%22debug%5C%22%2Fg'%20%2Fetc%2Finit.d%2Fdropbear%3B%20%2Fetc%2Finit.d%2Fdropbear%20start%3B%20echo%20-e%20'admin%5Cnadmin'%20%7C%20passwd%20root%3Bhttps://youtu.be/ZsPOiFS20AY

Una vez que tengáis hecho el tutorial, tendréis, por un lado ssh hasta actualizar el router, y, si configuráis las VLANs, se supone que aguantan entre versiones. Aunque, es recomendable que hagáis copia de seguridad de la configuración. Aunque no es una solución como cambiar a OpenWRT como vimos en el AC2100, no está mal y, en mi caso, me permite poder cambiar el AC2100 para poder usar la cobertura del propio de Xiaomi.

Si tenéis alguna duda, podéis ponerla aquí o en el propio vídeo de Youtube para poder intentar ayudaros.

Si no podéis ver el vídeo correctamente, podéis verlo aquí.

Compra: Mi router lo conseguí aquí.

¿Quieres montarte tu propio sistema Smart Home?

¿Te gustaría empezar poco a poco teniendo Google Home, Alexa o Home Assistant para controlar las luces, calefacción y otros electrodomésticos de la casa? ¡Te ayudamos! Entra en nuestro Grupo de Telégram de Domótica y también puedes entrar a nuestro Foro de Domótica donde podrás empezar a leer y preguntar tus dudas. Además, si quieres estar al tanto de las ofertas de domótica que salen a diario para poder hacerte un sistema de domótica low cost, entra a nuestro Canal de ofertas de domótica y no te perderás ni una o si lo prefieres y no tienes Telegram, puedes entrar a nuestra página de ofertas de domótica o Smart Home en Facebook. ¡Síguenos también en nuestro Facebook, Twitter o Instagram! ¡Te esperamos!

7 Comentarios

  1. Jose

    Hola.
    Tengo un asus RT-AC66U y una ont de jazztel.

    Quiero cambiarlo por el ax3600 dejando la ont, mi duda es el usuario y contraseña de ppoe es el usuario y contraseña para entrar en la ont?

    Gracias.

    Reply
  2. Alejandro

    Para Lowi he puesto esta configuracion pero no sirve, he sacado el user y password del router.
    He visto en un foro que el vlan es el 24 que me está fallando tengo el xiaomi AX1800 todo va perfecto segun el tuto,
    pongo en el script esto pero no conecta del ont:

    config interface ‘loopback’
    option ifname ‘lo’
    option proto ‘static’
    option ipaddr ‘127.0.0.1’
    option netmask ‘255.0.0.0’

    config switch
    option name ‘switch0’

    config interface ‘lan’
    option ifname ‘eth1 eth2 eth3’
    option force_link ‘1’
    option type ‘bridge’
    option proto ‘static’
    option ipaddr ‘192.168.31.1’
    option netmask ‘255.255.255.0’
    option ipv6 ‘0’
    option multicast_querier ‘0’
    option igmp_snooping ‘0’

    config interface ‘eth1’
    option ifname ‘eth1.24’
    option keepup ‘1’

    config interface ‘wan’
    option proto ‘pppoe’
    option username ‘LWNXXXXXXX@lowi’
    option ifname ‘eth1.24’
    option special ‘0’
    option mtu ‘1432’
    option password ‘XXXXXXXX’

    config interface ‘dhcp’
    option ifname ‘eth1.24’
    option proto ‘dhcp’

    Podrias ayudarme por favor tengo fibra 100mb

    Reply
    • eduardo

      Por lo que he visto, tienes posibilidad de ser VLAN 100 (En el caso de ser fibra Vodafone) o 24 (si eres NEBA). Prueba a cambiar el 24 por el 100 por ver si te funciona, el resto parece correcto (la duda es el mtu, que en el algunos casos también he visto que ponen 1492).

      Reply
  3. Anibal

    Buenas, lo primero, muchas gracias por el tuto. Yo tengo una duda: tengo adamo como proveedor de internet y se que para configurar las VLANs con otros routers (por ejemplo asus) uso para internet VID 604 Prioridad 1, sin tener que configurar usuario y password de ningun tipo. Con esto puedo, como digo, puedo configurar un router asus y tenerlo funcional sin tener que usar el propio router que me da adamo (solo el asus + ont). En el caso que tenga que configurar el ax3600, en el apartado de la interfaz wlan, puedo eliminar las lineas: option proto ‘pppoe’
    , option username ”orangeuser@orangeadsl’, option password ‘XXXXXXXX’ ??¿¿ o tengo que tenerlas obligatoriamente?. Lo digo porque por mas que llamo a Adamo, se niegan a darme esta informacion y como digo, con el router asus no he tenido que poner nada de esto, mil gracias anticipadas.

    Reply
  4. Salvador

    Hola Eduardo, que tal? me llamo Salvador, soy seguidor tuyo y estoy en el grupo de telegram. He seguido el tutorial y SÍ consigo que me funcione internet (tengo Movistar fibra ONT+ Router comtred vg8050). Lo que NO consigo es que funcione Netflix, he modificado el MTU a 1492, 1473, 1464, 1436, 1500….., he cambiado DNS… pero casi nunca consigo conectar con netflix… y cuando conecto tarda mucho en reproducir. Si vuelvo a colocar el router de Movistar sí funciona Netflix… aunque la red wifi se caiga a cada momento (por eso compré el ax3600), tengo algunas cosillas hechas en casa con Home assistant y creo que el router de Movistar no puede tirar con tantas cosas… jejejeje. He estado investigando por internet pero no consigo solucionar el problema, espero que puedas ayudarme. Saludossss y gracias por tu tiempo.

    Te adjunto la configuración del archivo network:

    config interface ‘loopback’
    option ifname ‘lo’
    option proto ‘static’
    option ipaddr ‘127.0.0.1’
    option netmask ‘255.0.0.0’

    config switch
    option name ‘switch0’

    config interface ‘lan’
    option ifname ‘eth2 eth3 eth4’
    option force_link ‘1’
    option type ‘bridge’
    option proto ‘static’
    option netmask ‘255.255.255.0’
    option ipv6 ‘0’
    option multicast_querier ‘0’
    option igmp_snooping ‘0’
    option ipaddr ‘192.168.1.1’

    config interface ‘eth1’
    option ifname ‘eth1.6’
    option keepup ‘1’

    config interface ‘dhcp’
    option ifname ‘eth1.6’
    option proto ‘dhcp’

    config interface ‘wan’
    option proto ‘pppoe’
    list dns ‘8.8.8.8’
    list dns ‘8.8.4.4’
    option peerdns ‘0’
    option username ‘adslppp@telefonicanetpa’
    option special ‘0’
    option mru ‘1436’
    option password ‘adslppp’
    option ifname ‘eth1.6’

    Reply
    • es3nric

      me pasa exactamente lo mismo pero con Yoigo, si bajo e MTU a 1492, tngo que tocarlo en la PS4 tambien para que funcione, pero Netflix desde Firestick deja de funcionar.

      Reply

Contestar

Tu e-mail no será publicadoRequired fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Lost Password

Registro